logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

freeglut-3.2.1.ebuild (1561B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit cmake-multilib
  5. DESCRIPTION="A free OpenGL utility toolkit, the open-sourced alternative to the GLUT library"
  6. HOMEPAGE="http://freeglut.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
  11. IUSE="debug static-libs wayland-only"
  12. RDEPEND="!wayland-only? (
  13. >=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
  14. >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
  15. >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
  16. >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
  17. >=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
  18. >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
  19. >=x11-libs/libXxf86vm-1.1.3[${MULTILIB_USEDEP}]
  20. )
  21. wayland-only? (
  22. media-libs/mesa[egl,gles1,gles2,${MULTILIB_USEDEP}]
  23. dev-libs/wayland[${MULTILIB_USEDEP}]
  24. x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
  25. )"
  26. DEPEND="${RDEPEND}
  27. !wayland-only? ( x11-base/xorg-proto )"
  28. BDEPEND="virtual/pkgconfig"
  29. PATCHES=( "${FILESDIR}"/${PN}-3.2.1-gcc10-fno-common.patch )
  30. HTML_DOCS=( doc/. )
  31. src_configure() {
  32. local mycmakeargs=(
  33. "-DFREEGLUT_BUILD_DEMOS=OFF"
  34. "-DFREEGLUT_BUILD_STATIC_LIBS=$(usex static-libs ON OFF)"
  35. "-DFREEGLUT_WAYLAND=$(usex wayland-only )"
  36. "-DFREEGLUT_GLES=$(usex wayland-only )"
  37. )
  38. cmake-multilib_src_configure
  39. }
  40. multilib_src_install() {
  41. cmake-utils_src_install
  42. cp "${D}"/usr/$(get_libdir)/pkgconfig/{,free}glut.pc
  43. }