logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

unifont-13.0.03.ebuild (1231B)


  1. # Copyright 2003-2020 Gentoo Authors
  2. # Copyright 2019-2021 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  3. # Distributed under the terms of the GNU General Public License v2
  4. EAPI=7
  5. inherit font toolchain-funcs
  6. DESCRIPTION="GNU Unifont - a Pan-Unicode X11 bitmap iso10646 font"
  7. HOMEPAGE="http://unifoundry.com/"
  8. SRC_URI="mirror://gnu/${PN}/${P}/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
  12. IUSE="fontforge utils"
  13. DEPEND="
  14. fontforge? (
  15. app-text/bdf2psf
  16. dev-lang/perl
  17. dev-perl/GD[png(-)]
  18. media-gfx/fontforge
  19. x11-apps/bdftopcf
  20. )
  21. "
  22. RDEPEND="
  23. utils? (
  24. dev-lang/perl
  25. dev-perl/GD[png(-)]
  26. )
  27. "
  28. src_prepare() {
  29. sed -i -e 's/install -s/install/' src/Makefile || die
  30. default
  31. }
  32. src_compile() {
  33. buildargs=(
  34. BUILDFONT=$(usex fontforge 1 '')
  35. CC="$(tc-getCC)"
  36. CFLAGS="${CFLAGS}"
  37. INSTALL="${INSTALL-install}"
  38. )
  39. if use fontforge || use utils; then
  40. emake "${buildargs[@]}"
  41. fi
  42. }
  43. src_install() {
  44. local installargs=(
  45. COMPRESS=0
  46. DESTDIR="${ED}"
  47. PCFDEST="${ED}${FONTDIR}"
  48. TTFDEST="${ED}${FONTDIR}"
  49. )
  50. use utils || installargs+=( -C font )
  51. emake "${buildargs[@]}" "${installargs[@]}" install
  52. font_xfont_config
  53. font_fontconfig
  54. }