logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

inria-fonts-1.200.ebuild (608B)


  1. # Copyright 1999-2021 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. MY_PN="InriaFonts"
  5. MY_P=${MY_PN}-${PV}
  6. inherit font
  7. DESCRIPTION="Inria Serif and Inria Sans Typeface"
  8. HOMEPAGE="https://black-foundry.com/work/inria/"
  9. SRC_URI="https://github.com/BlackFoundryCom/InriaFonts/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
  10. LICENSE="OFL-1.1"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. S="${WORKDIR}/${MY_P}"
  15. FONT_SUFFIX="ttf otf"
  16. FONT_S="${S}"
  17. src_prepare() {
  18. default
  19. mv "${S}"/fonts/*/TTF/*.ttf "${FONT_S}" || die
  20. mv "${S}"/fonts/*/OTF/*.otf "${FONT_S}" || die
  21. }