logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

aerc-9999.ebuild (828B)


  1. # Copyright 2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. DESCRIPTION="Asynchronous email client for your terminal, written in Go."
  5. HOMEPAGE="https://aerc-mail.org"
  6. if [[ ${PV} == 9999 ]]; then
  7. inherit git-r3
  8. EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/${PN}"
  9. else
  10. SRC_URI="https://git.sr.ht/~sircmpwn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  11. KEYWORDS="~amd64 ~arm ~arm64 ~x86"
  12. fi
  13. RESTRICT="network-sandbox"
  14. LICENSE="MIT"
  15. SLOT="0"
  16. IUSE="html"
  17. DEPEND="app-text/scdoc"
  18. RDEPEND="${DEPEND}
  19. || (
  20. dev-libs/libvterm
  21. dev-libs/libvterm-neovim
  22. )
  23. virtual/awk
  24. html? (
  25. net-proxy/dante
  26. || (
  27. virtual/w3m
  28. www-client/lynx
  29. www-client/links
  30. )
  31. )
  32. "
  33. BDEPEND=">=dev-lang/go-1.12.0"
  34. pkg_setup(){
  35. # aerc uses default PREFIX=/usr/local
  36. export PREFIX="${EPREFIX}/usr"
  37. }