logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

breeze-5.17.5.ebuild (577B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. KFMIN=5.64.0
  5. PVCUT=$(ver_cut 1-3)
  6. QTMIN=5.12.3
  7. inherit ecm kde.org
  8. DESCRIPTION="Breeze visual style for the Plasma desktop"
  9. HOMEPAGE="https://cgit.kde.org/breeze.git"
  10. LICENSE="GPL-2+"
  11. SLOT="5"
  12. KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
  13. IUSE="kwin"
  14. RDEPEND="kwin? ( >=kde-plasma/kdecoration-${PVCUT}:5 )"
  15. DEPEND="${RDEPEND}
  16. >=kde-frameworks/kpackage-${KFMIN}:5
  17. "
  18. src_configure() {
  19. local mycmakeargs=(
  20. -DWITH_DECORATIONS="$(usex kwin)"
  21. )
  22. ecm_src_configure
  23. }