logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

wio-9999.ebuild (660B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit meson
  5. if [[ "${PV}" == "9999" ]]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/wio"
  8. else
  9. KEYWORDS="~amd64"
  10. fi
  11. DESCRIPTION="Wayland Kiosk"
  12. HOMEPAGE="https://wio-project.org/"
  13. LICENSE="BSD"
  14. SLOT="0"
  15. IUSE=""
  16. # dev-libs/wayland provides wayland-server
  17. DEPEND="
  18. >=gui-libs/wlroots-0.6.0:=
  19. x11-libs/cairo:=
  20. dev-libs/wayland-protocols:=
  21. x11-libs/libxkbcommon:=
  22. dev-libs/wayland:=
  23. "
  24. RDEPEND="${DEPEND}"
  25. src_configure() {
  26. local emesonargs=(
  27. "-Dwerror=false"
  28. )
  29. meson_src_configure
  30. }