logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

waymonad-9999.ebuild (1183B)


  1. # Copyright 2018-2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CABAL_FEATURES="lib"
  5. inherit haskell-cabal
  6. if [[ $PV = 9999 ]]; then
  7. inherit git-r3
  8. EGIT_REPO_URI="https://github.com/waymonad/waymonad.git"
  9. EGIT_SUBMODULES=()
  10. else
  11. SRC_URI="https://github.com/waymonad/waymonad/archive/${PV}.tar.gz -> ${P}.tar.gz"
  12. KEYWORDS="~amd64"
  13. fi
  14. DESCRIPTION="wayland compositor based on ideas from and inspired by xmonad"
  15. HOMEPAGE="https://github.com/waymonad/waymonad"
  16. SLOT="0"
  17. # Shipped in GHC: containers, time, directory, unix, process, bytestring,
  18. # deepseq, template-haskell, ghc-prim
  19. DEPEND="
  20. dev-haskell/hsroots
  21. dev-haskell/hayland
  22. dev-haskell/clock
  23. dev-haskell/xkbcommon
  24. dev-haskell/composition
  25. dev-haskell/mtl
  26. dev-haskell/text
  27. dev-haskell/transformers
  28. dev-haskell/config-schema
  29. dev-haskell/config-value
  30. dev-haskell/xdg-basedir
  31. dev-haskell/network
  32. dev-haskell/data-default
  33. dev-haskell/semigroupoids
  34. dev-haskell/hfuse
  35. dev-haskell/formatting
  36. dev-haskell/stm
  37. dev-haskell/unliftio-core
  38. dev-haskell/unliftio
  39. dev-haskell/libinput
  40. dev-haskell/safe
  41. dev-haskell/waymonad-scanner
  42. "