logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

inaban-9999.ebuild (803B)


  1. # Copyright 2019-2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. if [[ "${PV}" == "9999" ]]; then
  5. inherit git-r3
  6. EGIT_REPO_URI="https://hacktivis.me/git/inaban.git"
  7. else
  8. KEYWORDS="~amd64"
  9. fi
  10. DESCRIPTION="Distrustful Tiling Wayland Compositor"
  11. HOMEPAGE="https://hacktivis.me/git/inaban/"
  12. LICENSE="BSD"
  13. SLOT="0"
  14. IUSE=""
  15. # dev-libs/wayland provides wayland-server
  16. DEPEND="
  17. >=gui-libs/wlroots-0.6.0:=
  18. dev-libs/wayland-protocols:=
  19. x11-libs/libxkbcommon:=
  20. dev-libs/wayland:=
  21. "
  22. RDEPEND="${DEPEND}"
  23. src_compile() {
  24. emake \
  25. CC="${CC:-cc}" \
  26. CFLAGS="${CFLAGS:--02 -Wall -Wextra}" \
  27. LDFLAGS="${LDFLAGS}" \
  28. PREFIX="/usr"
  29. }
  30. src_install() {
  31. emake \
  32. DESTDIR="${D}" \
  33. PREFIX="/usr" \
  34. install
  35. einstalldocs
  36. }