logo

overlay

My (experimental) gentoo overlay

cage-0.1.ebuild (757B)


      1 # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit meson
      7 
      8 DESCRIPTION="Wayland Kiosk"
      9 HOMEPAGE="https://hjdskes.nl/projects/cage"
     10 SRC_URI="https://github.com/Hjdskes/cage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
     11 LICENSE="MIT"
     12 SLOT="0"
     13 KEYWORDS="~amd64"
     14 IUSE="xwayland"
     15 
     16 # dev-libs/wayland provides wayland-server, wayland-scanner
     17 DEPEND="
     18 	>=gui-libs/wlroots-0.5.0:=
     19 	!>gui-libs/wlroots-0.6
     20 	xwayland? ( gui-libs/wlroots[X] )
     21 	>=dev-libs/wayland-protocols-1.14:=
     22 	x11-libs/pixman:=
     23 	x11-libs/libxkbcommon:=
     24 	dev-libs/wayland:=
     25 "
     26 RDEPEND="${DEPEND}"
     27 
     28 src_configure() {
     29 	local emesonargs=(
     30 		"$(meson_use xwayland)"
     31 		"-Dwerror=false"
     32 	)
     33 
     34 	meson_src_configure
     35 }