logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

cage-0.1.1.ebuild (847B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit meson
  5. if [[ "${PV}" == "9999" ]]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://github.com/Hjdskes/cage"
  8. else
  9. SRC_URI="https://github.com/Hjdskes/cage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  10. KEYWORDS="~amd64"
  11. fi
  12. DESCRIPTION="Wayland Kiosk"
  13. HOMEPAGE="https://www.hjdskes.nl/projects/cage/"
  14. LICENSE="MIT"
  15. SLOT="0"
  16. IUSE="xwayland"
  17. # dev-libs/wayland provides wayland-server, wayland-scanner
  18. DEPEND="
  19. >=gui-libs/wlroots-0.6.0:=
  20. xwayland? ( gui-libs/wlroots[X] )
  21. >=dev-libs/wayland-protocols-1.14:=
  22. x11-libs/pixman:=
  23. x11-libs/libxkbcommon:=
  24. dev-libs/wayland:=
  25. "
  26. RDEPEND="${DEPEND}"
  27. src_configure() {
  28. local emesonargs=(
  29. "$(meson_use xwayland)"
  30. "-Dwerror=false"
  31. )
  32. meson_src_configure
  33. }