logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

wlroots-0.15.0.ebuild (1685B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit meson
  5. DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
  6. HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
  7. if [[ ${PV} == 9999 ]]; then
  8. EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
  9. inherit git-r3
  10. SLOT="0/9999"
  11. else
  12. SRC_URI="https://gitlab.freedesktop.org/wlroots/wlroots/-/releases/${PV}/downloads/${P}.tar.gz"
  13. KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
  14. SLOT="0/15"
  15. fi
  16. LICENSE="MIT"
  17. IUSE="vulkan x11-backend X"
  18. DEPEND="
  19. >=dev-libs/libinput-1.14.0:0=
  20. >=dev-libs/wayland-1.20.0
  21. >=dev-libs/wayland-protocols-1.24
  22. media-libs/mesa[egl(+),gles2,gbm(+)]
  23. sys-auth/seatd:=
  24. virtual/libudev
  25. vulkan? (
  26. dev-util/glslang:0=
  27. dev-util/vulkan-headers:0=
  28. media-libs/vulkan-loader:0=
  29. )
  30. >=x11-libs/libdrm-2.4.109
  31. x11-libs/libxkbcommon
  32. x11-libs/pixman
  33. x11-backend? ( x11-libs/libxcb:0= )
  34. X? (
  35. x11-base/xwayland
  36. x11-libs/libxcb:0=
  37. x11-libs/xcb-util-image
  38. x11-libs/xcb-util-wm
  39. )
  40. "
  41. RDEPEND="
  42. ${DEPEND}
  43. "
  44. BDEPEND="
  45. >=dev-libs/wayland-protocols-1.24
  46. >=dev-util/meson-0.60.0
  47. virtual/pkgconfig
  48. "
  49. src_configure() {
  50. # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
  51. local emesonargs=(
  52. "-Dxcb-errors=disabled"
  53. "-Dexamples=false"
  54. "-Dwerror=false"
  55. -Drenderers=$(usex vulkan 'gles2,vulkan' gles2)
  56. -Dxwayland=$(usex X enabled disabled)
  57. -Dbackends=drm,libinput$(usex x11-backend ',x11' '')
  58. )
  59. meson_src_configure
  60. }
  61. pkg_postinst() {
  62. elog "You must be in the input group to allow your compositor"
  63. elog "to access input devices via libinput."
  64. }