logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

wlr-protocols-1.0_p20220608.ebuild (692B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. if [ "${PV}" = 9999 ]; then
  5. inherit git-r3
  6. EGIT_REPO_URI="https://gitlab.freedesktop.org/wlroots/wlr-protocols.git"
  7. else
  8. EGIT_COMMIT="4264185db3b7e961e7f157e1cc4fd0ab75137568"
  9. SRC_URI="https://gitlab.freedesktop.org/wlroots/wlr-protocols/-/archive/${EGIT_COMMIT}/${PN}-${EGIT_COMMIT}.tar.gz"
  10. S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
  11. KEYWORDS="~amd64"
  12. fi
  13. DESCRIPTION="Wayland protocols designed for use in wlroots (and other compositors)"
  14. HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlr-protocols"
  15. LICENSE="MIT"
  16. SLOT="0"
  17. src_compile() { :; }