logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libwpe-1.6.0.ebuild (621B)


  1. # Copyright 2019-2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CMAKE_MAKEFILE_GENERATOR="ninja"
  5. inherit cmake
  6. DESCRIPTION="WebKit port optimized for embedded devices"
  7. HOMEPAGE="https://wpewebkit.org/"
  8. LICENSE="BSD-2"
  9. SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
  10. SLOT="1.0" # WPE_API_VERSION
  11. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
  12. IUSE=""
  13. # documentation depends on hotdoc
  14. RDEPEND="
  15. media-libs/mesa[egl]
  16. x11-libs/libxkbcommon:=
  17. "
  18. DEPEND="${RDEPEND}"