logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libdecor-0.1.1.ebuild (1061B)


  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit meson
  5. if [[ ${PV} == 9999 ]]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://gitlab.freedesktop.org/libdecor/libdecor.git"
  8. else
  9. SRC_URI="https://gitlab.freedesktop.org/libdecor/libdecor/-/archive/${PV}/${P}.tar.gz"
  10. KEYWORDS="~amd64"
  11. fi
  12. DESCRIPTION="A client-side decorations library for Wayland clients"
  13. HOMEPAGE="https://gitlab.freedesktop.org/libdecor/libdecor"
  14. LICENSE="MIT"
  15. SLOT="0"
  16. IUSE="+dbus examples"
  17. DEPEND="
  18. >=dev-libs/wayland-1.18
  19. >=dev-libs/wayland-protocols-1.15
  20. x11-libs/pango
  21. dbus? ( sys-apps/dbus )
  22. examples? (
  23. virtual/opengl
  24. dev-libs/wayland
  25. media-libs/mesa[egl(+)]
  26. x11-libs/libxkbcommon
  27. )
  28. "
  29. RDEPEND="${DEPEND}"
  30. BDEPEND="
  31. >=dev-util/meson-0.47
  32. examples? ( dev-libs/wayland-protocols )
  33. "
  34. src_configure() {
  35. local emesonargs=(
  36. # Avoid auto-magic, built-in feature of meson
  37. -Dauto_features=disabled
  38. $(meson_feature dbus)
  39. $(meson_use examples demo)
  40. -Dinstall_demo=true
  41. )
  42. meson_src_configure
  43. }