logo

overlay

My (experimental) gentoo overlay

slurp-1.2.0.ebuild (564B)


      1 # Copyright 1999-2019 Gentoo Foundation
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit meson
      7 
      8 DESCRIPTION="Select a region in a Wayland compositor and print it to stdout"
      9 HOMEPAGE="https://wayland.emersion.fr/slurp"
     10 SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
     11 
     12 LICENSE="MIT"
     13 SLOT="0"
     14 KEYWORDS="~amd64 ~x86"
     15 IUSE=""
     16 
     17 RDEPEND="
     18 	x11-libs/cairo:=
     19 	dev-libs/wayland:=
     20 "
     21 
     22 DEPEND="
     23 	${DEPEND}
     24 	app-text/scdoc
     25 "
     26 
     27 src_configure() {
     28 	local emesonargs=(
     29 		"-Dwerror=false"
     30 	)
     31 
     32 	meson_src_configure
     33 }