logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

cog-9999.ebuild (1523B)


  1. # Copyright 2021-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit meson git-r3
  5. DESCRIPTION="Single Window Launcher for WPE WebKit"
  6. HOMEPAGE="https://github.com/Igalia/cog"
  7. EGIT_REPO_URI="https://github.com/Igalia/cog.git"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. IUSE="+drm gtk4 headless wayland X"
  11. # note: cogcore_dep is ./core/
  12. cogplatformcommon_dep="media-libs/libepoxy"
  13. wpebackend_fdo_dep=">=gui-libs/wpebackend-fdo-1.8.0"
  14. DEPEND="
  15. net-libs/wpewebkit:1.1=[X?]
  16. net-libs/libsoup:3.0
  17. drm? (
  18. ${cogplatformcommon_dep}
  19. ${wpebackend_fdo_dep}
  20. >=x11-libs/libdrm-2.4.71
  21. dev-libs/libinput:=
  22. virtual/libudev:=
  23. )
  24. gtk4? (
  25. ${cogplatformcommon_dep}
  26. ${wpebackend_fdo_dep}
  27. gui-libs/gtk:4
  28. )
  29. headless? ( ${wpebackend_fdo_dep} )
  30. wayland? (
  31. ${wpebackend_fdo_dep}
  32. x11-libs/cairo
  33. media-libs/mesa[egl(+)]
  34. dev-libs/wayland
  35. dev-libs/wayland-protocols
  36. x11-libs/libxkbcommon
  37. )
  38. X? (
  39. ${wpebackend_fdo_dep}
  40. ${cogplatformcommon_dep}
  41. media-libs/mesa[egl(+)]
  42. x11-libs/libxcb
  43. x11-libs/libxkbcommon[X]
  44. x11-libs/libX11
  45. )
  46. "
  47. RDEPEND="${DEPEND}"
  48. BDEPEND="
  49. dev-util/meson-format-array
  50. wayland? ( dev-util/wayland-scanner )
  51. "
  52. src_configure() {
  53. local platforms=(
  54. $(usev drm)
  55. $(usev headless)
  56. $(usev wayland)
  57. $(usev gtk4)
  58. )
  59. use X && platforms+=( 'x11' )
  60. local emesonargs=(
  61. -Dsoup2=disabled
  62. -Dplatforms="$(meson-format-array ${platforms[@]})"
  63. -Dwayland_weston_direct_display=false
  64. -Dwayland_weston_content_protection=false
  65. )
  66. meson_src_configure
  67. }