logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gvfs-1.32.2.ebuild (3834B)


  1. # Copyright 1999-2018 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. GNOME2_EAUTORECONF="yes"
  6. inherit gnome2 systemd
  7. DESCRIPTION="Virtual filesystem implementation for gio"
  8. HOMEPAGE="https://wiki.gnome.org/Projects/gvfs"
  9. SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${P}-patchset.tar.xz"
  10. LICENSE="LGPL-2+"
  11. SLOT="0"
  12. IUSE="afp archive bluray cdda elogind fuse google gnome-keyring gnome-online-accounts gphoto2 gtk +http ios mtp nfs policykit samba sftp systemd test +udev udisks zeroconf"
  13. REQUIRED_USE="
  14. cdda? ( udev )
  15. elogind? ( !systemd udisks )
  16. google? ( gnome-online-accounts )
  17. mtp? ( udev )
  18. udisks? ( udev )
  19. systemd? ( !elogind udisks )
  20. "
  21. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
  22. RDEPEND="
  23. app-crypt/gcr:=
  24. >=dev-libs/glib-2.51:2
  25. dev-libs/libxml2:2
  26. sftp? ( net-misc/openssh )
  27. afp? ( >=dev-libs/libgcrypt-1.2.2:0= )
  28. archive? ( app-arch/libarchive:= )
  29. bluray? ( media-libs/libbluray:= )
  30. elogind? ( >=sys-auth/elogind-229:0= )
  31. fuse? ( >=sys-fs/fuse-2.8.0:0 )
  32. gnome-keyring? ( app-crypt/libsecret )
  33. gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.7.1:= )
  34. google? (
  35. >=dev-libs/libgdata-0.17.7:=[crypt,gnome-online-accounts]
  36. >=net-libs/gnome-online-accounts-3.17.1:= )
  37. gphoto2? ( >=media-libs/libgphoto2-2.5.0:= )
  38. gtk? ( >=x11-libs/gtk+-3.0:3 )
  39. http? ( >=net-libs/libsoup-2.42:2.4 )
  40. ios? (
  41. >=app-pda/libimobiledevice-1.2:=
  42. >=app-pda/libplist-1:= )
  43. mtp? (
  44. >=dev-libs/libusb-1.0.21
  45. >=media-libs/libmtp-1.1.12 )
  46. nfs? ( >=net-fs/libnfs-1.9.8 )
  47. policykit? (
  48. sys-auth/polkit
  49. sys-libs/libcap )
  50. samba? ( >=net-fs/samba-4[client] )
  51. systemd? ( >=sys-apps/systemd-206:0= )
  52. udev? (
  53. cdda? ( dev-libs/libcdio-paranoia )
  54. >=virtual/libgudev-147:=
  55. virtual/libudev:= )
  56. udisks? ( >=sys-fs/udisks-1.97:2 )
  57. zeroconf? ( >=net-dns/avahi-0.6 )
  58. "
  59. DEPEND="${RDEPEND}
  60. app-text/docbook-xsl-stylesheets
  61. dev-libs/libxslt
  62. >=sys-devel/gettext-0.19.4
  63. virtual/pkgconfig
  64. dev-util/gdbus-codegen
  65. dev-util/glib-utils
  66. dev-util/gtk-doc-am
  67. test? (
  68. >=dev-python/twisted-16
  69. || (
  70. net-analyzer/netcat
  71. net-analyzer/netcat6 ) )
  72. !udev? ( >=dev-libs/libgcrypt-1.2.2:0 )
  73. "
  74. # libgcrypt.m4, provided by libgcrypt, needed for eautoreconf, bug #399043
  75. # test dependencies needed per https://bugzilla.gnome.org/700162
  76. # Tests with multiple failures, this is being handled upstream at:
  77. # https://bugzilla.gnome.org/700162
  78. RESTRICT="test"
  79. PATCHES=(
  80. "${WORKDIR}"/patches/ #599482, 641522, gnome-3-24 backports
  81. "${FILESDIR}"/${PN}-1.30.2-sysmacros.patch #580234
  82. )
  83. src_prepare() {
  84. if ! use udev; then
  85. sed -e 's/gvfsd-burn/ /' \
  86. -e 's/burn.mount.in/ /' \
  87. -e 's/burn.mount/ /' \
  88. -i daemon/Makefile.am || die
  89. fi
  90. gnome2_src_prepare
  91. }
  92. src_configure() {
  93. # --enable-documentation installs man pages
  94. # --disable-obexftp, upstream bug #729945
  95. gnome2_src_configure \
  96. --disable-gdu \
  97. --enable-documentation \
  98. --enable-gcr \
  99. --with-dbus-service-dir="${EPREFIX}"/usr/share/dbus-1/services \
  100. --with-systemduserunitdir="$(systemd_get_userunitdir)" \
  101. $(use_enable afp) \
  102. $(use_enable archive) \
  103. $(use_enable bluray) \
  104. $(use_enable cdda) \
  105. $(use_enable elogind libelogind) \
  106. $(use_enable fuse) \
  107. $(use_enable gnome-keyring keyring) \
  108. $(use_enable gnome-online-accounts goa) \
  109. $(use_enable google) \
  110. $(use_enable gphoto2) \
  111. $(use_enable gtk) \
  112. $(use_enable http) \
  113. $(use_enable ios afc) \
  114. $(use_enable mtp libmtp) \
  115. $(use_enable mtp libusb) \
  116. $(use_enable nfs) \
  117. $(use_enable policykit admin) \
  118. $(use_enable samba) \
  119. $(use_enable sftp) \
  120. $(use_enable systemd libsystemd-login) \
  121. $(use_enable udev gudev) \
  122. $(use_enable udev) \
  123. $(use_enable udisks udisks2) \
  124. $(use_enable zeroconf avahi)
  125. }