logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

steamcontroller-9999.ebuild (599B)


  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_SINGLE_IMPL=1
  5. DISTUTILS_USE_SETUPTOOLS=no
  6. PYTHON_COMPAT=( python3_{7..10} )
  7. inherit distutils-r1 git-r3
  8. DESCRIPTION="Standalone Steam Controller Driver"
  9. HOMEPAGE="https://github.com/ynsta/steamcontroller"
  10. EGIT_REPO_URI="https://github.com/ynsta/steamcontroller"
  11. LICENSE="MIT"
  12. SLOT="0"
  13. KEYWORDS=""
  14. IUSE="+udev"
  15. RDEPEND="
  16. $(python_gen_cond_dep '
  17. dev-python/libusb1[${PYTHON_USEDEP}]
  18. dev-python/psutil[${PYTHON_USEDEP}]
  19. ')
  20. udev? ( games-util/game-device-udev-rules )
  21. "