logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

fteqcc-9999.ebuild (615B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit subversion edos2unix toolchain-funcs
  5. DESCRIPTION="FTE QuakeC compiler"
  6. HOMEPAGE="http://fteqw.sourceforge.net/"
  7. ESVN_REPO_URI="https://svn.code.sf.net/p/fteqw/code/trunk"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. RESTRICT="test"
  11. src_prepare() {
  12. default
  13. # Thanks subversion.eclass for targetting ${S} instead of ${WORKDIR}
  14. export S="${WORKDIR}/${P}/engine/qclib/"
  15. cd "${S}" || die
  16. edos2unix readme.txt
  17. }
  18. src_configure() {
  19. tc-export CC
  20. }
  21. src_install() {
  22. newbin fteqcc.bin fteqcc
  23. dodoc readme.txt
  24. }