logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

glsmac-9999.ebuild (907B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3 cmake
  5. DESCRIPTION="Open-source reimplementation of Sid Meier's Alpha Centauri (+ Alien Crossfire)"
  6. HOMEPAGE="https://github.com/afwbkbc/glsmac"
  7. EGIT_REPO_URI="https://github.com/afwbkbc/glsmac"
  8. LICENSE="AGPL-3"
  9. SLOT="0"
  10. RDEPEND="
  11. media-libs/libsdl2
  12. media-libs/sdl2-image
  13. media-libs/freetype
  14. media-libs/glew
  15. "
  16. DEPEND="${RDEPEND}"
  17. CMAKE_BUILD_TYPE="Release"
  18. src_prepare() {
  19. cmake_src_prepare
  20. # Should only be active for Windows but better be sure
  21. rm -r dependencies || die
  22. }
  23. src_install() {
  24. einstalldocs
  25. dobin "${BUILD_DIR}/bin/GLSMAC"
  26. }
  27. pkg_postinst() {
  28. einfo "You'll need to run GLSMAC in an unpacked version of Alpha Centauri, or point to it for example:"
  29. einfo " $ GLSMAC --smacpath ~/Games/GOG/sid_meiers_alpha_centauri/app/"
  30. }