logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

glsmac-9999.ebuild (927B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3 cmake
  5. DESCRIPTION="Open-source reimplementation of Sid Meier's Alpha Centauri (+ Alien Crossfire)"
  6. HOMEPAGE="https://github.com/afwbkbc/glsmac"
  7. EGIT_REPO_URI="https://github.com/afwbkbc/glsmac"
  8. LICENSE="AGPL-3"
  9. SLOT="0"
  10. RDEPEND="
  11. media-libs/libsdl2
  12. media-libs/sdl2-image
  13. media-libs/freetype
  14. media-libs/glew
  15. dev-libs/ossp-uuid
  16. "
  17. DEPEND="${RDEPEND}"
  18. CMAKE_BUILD_TYPE="Release"
  19. src_prepare() {
  20. cmake_src_prepare
  21. # Should only be active for Windows but better be sure
  22. rm -r dependencies || die
  23. }
  24. src_install() {
  25. einstalldocs
  26. dobin "${BUILD_DIR}/bin/GLSMAC"
  27. }
  28. pkg_postinst() {
  29. einfo "You'll need to run GLSMAC in an unpacked version of Alpha Centauri, or point to it for example:"
  30. einfo " $ GLSMAC --smacpath ~/Games/GOG/sid_meiers_alpha_centauri/app/"
  31. }