logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

vdrift-9999.ebuild (1055B)


  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Copyright 2019-2021 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  3. # Distributed under the terms of the GNU General Public License v2
  4. EAPI=7
  5. PYTHON_COMPAT=( python3_{7,8,9} )
  6. inherit python-any-r1 scons-utils
  7. MY_P="${PN}-$(ver_rs 1-2 -)"
  8. if [ "${PV}" == "9999" ]; then
  9. inherit git-r3
  10. EGIT_REPO_URI="https://github.com/VDrift/vdrift"
  11. else
  12. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
  13. KEYWORDS="~amd64 ~x86"
  14. fi
  15. DESCRIPTION="A driving simulation made with drift racing in mind"
  16. HOMEPAGE="https://vdrift.net/"
  17. LICENSE="GPL-3 ZLIB LGPL-2.1+"
  18. SLOT="0"
  19. S="${WORKDIR}/${PN}"
  20. RDEPEND="
  21. media-libs/libsdl2[opengl,video]
  22. media-libs/sdl2-image[png]
  23. media-libs/libvorbis
  24. net-misc/curl
  25. sci-physics/bullet[-double-precision]
  26. "
  27. DEPEND="${RDEPEND}"
  28. src_configure() {
  29. MYSCONS=(
  30. destdir="${D}"
  31. prefix=/usr
  32. release=1
  33. os_cc=1
  34. os_cxx=1
  35. os_cxxflags=1
  36. force_feedback=1
  37. )
  38. }
  39. src_compile() {
  40. escons "${MYSCONS[@]}"
  41. }
  42. src_install() {
  43. escons "${MYSCONS[@]}" DESTDIR="${D}" install
  44. default
  45. }