logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

vdrift-2014.10.20.ebuild (1040B)


  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Copyright 2019-2021 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  3. # Distributed under the terms of the GNU General Public License v2
  4. EAPI=7
  5. PYTHON_COMPAT=( python3_{7,8,9} )
  6. inherit python-any-r1 scons-utils
  7. MY_P="${PN}-$(ver_rs 1-2 -)"
  8. DESCRIPTION="A driving simulation made with drift racing in mind"
  9. HOMEPAGE="https://vdrift.net/"
  10. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
  11. LICENSE="GPL-3 ZLIB LGPL-2.1+"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. S="${WORKDIR}/${PN}"
  16. RDEPEND="
  17. media-libs/libsdl2[opengl,video]
  18. media-libs/sdl2-image[png]
  19. media-libs/libvorbis
  20. net-misc/curl
  21. sci-physics/bullet[-double-precision]
  22. "
  23. DEPEND="${RDEPEND}"
  24. PATCHES=(
  25. "${FILESDIR}/${P}-gcc6.patch"
  26. "${FILESDIR}/${P}-scons-python3.patch"
  27. )
  28. src_configure() {
  29. MYSCONS=(
  30. destdir="${D}"
  31. prefix=/usr
  32. release=1
  33. os_cc=1
  34. os_cxx=1
  35. os_cxxflags=1
  36. force_feedback=1
  37. )
  38. }
  39. src_compile() {
  40. escons "${MYSCONS[@]}"
  41. }
  42. src_install() {
  43. escons "${MYSCONS[@]}" DESTDIR="${D}" install
  44. default
  45. }