logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

ponysay-3.0.3.ebuild (1454B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python3_{6,7} )
  5. inherit bash-completion-r1 python-single-r1
  6. DESCRIPTION="cowsay reimplemention for ponies"
  7. HOMEPAGE="https://github.com/erkin/ponysay"
  8. SRC_URI="https://github.com/erkin/ponysay/archive/3.0.2.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="doc +non-free bash-completion fish-completion zsh-completion"
  13. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  14. DEPEND="${PYTHON_DEPS}
  15. doc? ( sys-apps/texinfo )"
  16. RDEPEND="${PYTHON_DEPS}
  17. fish-completion? ( app-shells/fish )
  18. zsh-completion? ( app-shells/zsh )"
  19. setup_py() {
  20. "${PYTHON}" setup.py \
  21. --prefix="${EPREFIX}"/usr \
  22. --everything \
  23. --without-info-compression \
  24. --without-man-compression \
  25. --without-pdf-compression \
  26. --without-shared-cache \
  27. --freedom=$(usex non-free no yes) \
  28. $(use_with fish-completion) \
  29. $(use_with zsh-completion) \
  30. $(use_with doc info) \
  31. $(use_with doc pdf "${EPREFIX}"/usr/share/doc/${PF}) \
  32. "${@}" || die
  33. }
  34. src_compile() {
  35. setup_py \
  36. $(use_with bash-completion) \
  37. build
  38. }
  39. src_install() {
  40. setup_py \
  41. --without-bash-completion \
  42. --destdir="${D}" \
  43. prebuilt
  44. python_fix_shebang "${ED}"/usr/bin/${PN}
  45. rm -rv "${ED}"/usr/share/licenses || die
  46. dodoc CHANGELOG CONTRIBUTING CREDITS README.md
  47. use bash-completion &&
  48. newbashcomp completion/bash-completion.${PN}.install ${PN}
  49. }