logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

papers-please-1.2.76.54233-r1.ebuild (864B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit unpacker
  5. MY_PV="$(ver_rs 1- _)"
  6. DESCRIPTION="A Dystopian Document Thriller"
  7. HOMEPAGE="https://www.gog.com/game/papers_please https://papersplea.se/"
  8. SRC_URI="papers_please_1_2_76_54233.sh"
  9. S="${WORKDIR}"
  10. LICENSE="PAPERS-PLEASE"
  11. SLOT="0"
  12. KEYWORDS="~amd64"
  13. dir="/opt/${PN}"
  14. RESTRICT="bindist fetch strip"
  15. QA_PREBUILT="opt/${PN}/*"
  16. BDEPEND="app-arch/unzip"
  17. pkg_nofetch() {
  18. einfo
  19. einfo "Please buy & download ${SRC_URI} from:"
  20. einfo " ${HOMEPAGE}"
  21. einfo "and move it to your DISTDIR directory."
  22. einfo
  23. }
  24. src_unpack() {
  25. unpack_zip ${A}
  26. }
  27. src_install() {
  28. insinto ${dir}
  29. doins -r data/noarch/game/*
  30. exeinto "${dir}"
  31. doexe data/noarch/game/PapersPlease
  32. dosym "${dir}/PapersPlease" "/usr/bin/${PN}"
  33. }