logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

rtcw-data-gog-2.0.0.2.ebuild (737B)


  1. # Copyright 2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Data files for Return To Castle Wolfenstein (RTCW) from gog.com"
  5. HOMEPAGE="https://www.gog.com/game/return_to_castle_wolfenstein"
  6. SRC_URI="setup_return_to_castle_wolfenstein_${PV}.exe"
  7. LICENSE="GOG-EULA"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~arm ~m68k ~x86"
  10. RESTRICT="bindist fetch"
  11. BDEPEND="app-arch/innoextract"
  12. S="${WORKDIR}"
  13. pkg_nofetch() {
  14. einfo "Please buy and download ${SRC_URI} from:"
  15. einfo " ${HOMEPAGE}"
  16. einfo "and move it to your distfiles directory."
  17. }
  18. src_install() {
  19. innoextract --extract --lowercase \
  20. --include=/app/Main \
  21. "${DISTDIR}/${A}" || die
  22. insinto /usr/share/wolf
  23. doins app/main/*.pk3
  24. }