logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

solarus-1.6.5.ebuild (1193B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. LUA_COMPAT=( lua5-1 luajit )
  5. inherit cmake lua-single virtualx
  6. DESCRIPTION="An open-source Zelda-like 2D game engine"
  7. HOMEPAGE="https://www.solarus-games.org/"
  8. SRC_URI="https://gitlab.com/solarus-games/solarus/-/archive/v${PV}/solarus-v${PV}.tar.gz"
  9. S="${WORKDIR}/${PN}-v${PV}"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="doc qt5 test"
  14. RESTRICT="!test? ( test )"
  15. RDEPEND="
  16. ${LUA_DEPS}
  17. dev-games/physfs
  18. media-libs/glm
  19. media-libs/libmodplug
  20. media-libs/libsdl2[X,joystick,video]
  21. media-libs/libvorbis
  22. media-libs/openal
  23. virtual/opengl
  24. media-libs/sdl2-image[png]
  25. media-libs/sdl2-ttf
  26. qt5? ( dev-qt/qtgui:5 )
  27. "
  28. DEPEND="
  29. ${RDEPEND}
  30. doc? ( app-doc/doxygen )
  31. "
  32. src_prepare() {
  33. cmake_src_prepare
  34. }
  35. src_configure() {
  36. local mycmakeargs=(
  37. -DSOLARUS_USE_LUAJIT="$(usex lua_single_target_luajit)"
  38. -DSOLARUS_GUI="$(usex qt5)"
  39. )
  40. cmake_src_configure
  41. }
  42. src_compile() {
  43. cmake_src_compile
  44. if use doc ; then
  45. cd doc || die
  46. doxygen || die
  47. fi
  48. }
  49. src_test() {
  50. virtx cmake_src_test
  51. }
  52. src_install() {
  53. cmake_src_install
  54. use doc && dodoc -r doc/${PV%.*}/html/*
  55. }