logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

solarus-1.5.3.ebuild (1094B)


  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="An open-source Zelda-like 2D game engine"
  6. HOMEPAGE="https://www.solarus-games.org/"
  7. SRC_URI="https://www.solarus-games.org/downloads/${PN}/${P}-src.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="doc luajit qt5"
  12. RDEPEND="
  13. dev-games/physfs
  14. media-libs/libmodplug
  15. media-libs/libsdl2[X,joystick,video]
  16. media-libs/libvorbis
  17. media-libs/openal
  18. media-libs/sdl2-image[png]
  19. media-libs/sdl2-ttf
  20. media-libs/glm
  21. luajit? ( dev-lang/luajit:2 )
  22. !luajit? ( dev-lang/lua:0 )
  23. qt5? ( dev-qt/qtgui:5 )
  24. "
  25. DEPEND="${RDEPEND}
  26. doc? ( app-doc/doxygen )"
  27. src_prepare() {
  28. cmake-utils_src_prepare
  29. }
  30. src_configure() {
  31. local mycmakeargs=(
  32. -DSOLARUS_USE_LUAJIT="$(usex luajit)"
  33. -DSOLARUS_GUI="$(usex qt5)"
  34. )
  35. cmake-utils_src_configure
  36. }
  37. src_compile() {
  38. cmake-utils_src_compile
  39. if use doc ; then
  40. cd doc || die
  41. doxygen || die
  42. fi
  43. }
  44. src_install() {
  45. cmake-utils_src_install
  46. doman solarus.6
  47. use doc && dodoc -r doc/${PV%.*}/html/*
  48. }