logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

nxengine-evo-2.6.3.ebuild (892B)


  1. # Copyright 2018 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="rewrite of the jump-and-run platformer Doukutsu Monogatari(Cave Story)"
  6. HOMEPAGE="https://github.com/nxengine/nxengine-evo http://nxengine.sourceforge.net/"
  7. SRC_URI="
  8. https://github.com/nxengine/nxengine-evo/archive/v${PV}.tar.gz -> ${P}.tar.gz
  9. https://www.cavestory.org/downloads/cavestoryen.zip
  10. "
  11. SLOT="0"
  12. LICENSE="GPL-3"
  13. KEYWORDS="~amd64"
  14. DEPENDS="
  15. media-libs/libpng:=
  16. media-libs/libsdl2:=
  17. media-libs/sdl2-mixer:=
  18. media-libs/sdl2-ttf:=
  19. "
  20. src_compile() {
  21. cmake-utils_src_compile
  22. cp -r data/ "${WORKDIR}/CaveStory"
  23. cd "${WORKDIR}/CaveStory"
  24. ${S}/bin/extract
  25. }
  26. src_install() {
  27. newbin bin/extract nx-extract
  28. dobin bin/nx
  29. dodir /usr/share
  30. cp -r "${WORKDIR}/CaveStory/" "${ED}/usr/share/nxengine"
  31. }