logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

devilutionx-9999.ebuild (1113B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit cmake-utils
  5. DESCRIPTION="Diablo build for modern operating systems"
  6. HOMEPAGE="https://github.com/diasurgical/devilutionX"
  7. if [[ "${PV}" == 9999 ]] ; then
  8. inherit git-r3
  9. EGIT_REPO_URI="https://github.com/diasurgical/devilutionX.git"
  10. else
  11. SRC_URI="https://github.com/diasurgical/devilutionX/archive/${PV}.tar.gz -> ${P}.tar.gz"
  12. S="${WORKDIR}/devilutionX-${PV}"
  13. KEYWORDS="~amd64 ~x86"
  14. fi
  15. LICENSE="Unlicense"
  16. SLOT="0"
  17. IUSE="debug"
  18. RDEPEND="
  19. dev-libs/libsodium
  20. media-libs/libsdl2[haptic]
  21. media-libs/sdl2-mixer
  22. media-libs/sdl2-ttf
  23. "
  24. DEPEND="${RDEPEND}"
  25. BDEPEND="
  26. virtual/pkgconfig
  27. "
  28. src_configure() {
  29. local mycmakeargs=(
  30. -DBINARY_RELEASE=ON
  31. -DDEBUG="$(usex debug)"
  32. )
  33. cmake-utils_src_configure
  34. }
  35. pkg_postinst() {
  36. einfo "In order to play the game you need to install the file"
  37. einfo " diabdat.mpq"
  38. einfo "from the original game CD into the following directory:"
  39. einfo " \${HOME}/.local/share/diasurgical/devilution/"
  40. einfo "and make sure it's writeable (chmod u+w)."
  41. }