logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

devilutionx-1.0.0.ebuild (1196B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CMAKE_MAKEFILE_GENERATOR=emake
  5. inherit cmake-utils
  6. DESCRIPTION="Diablo build for modern operating systems"
  7. HOMEPAGE="https://github.com/diasurgical/devilutionX"
  8. if [[ "${PV}" == 9999 ]] ; then
  9. inherit git-r3
  10. EGIT_REPO_URI="https://github.com/diasurgical/devilutionX.git"
  11. else
  12. SRC_URI="https://github.com/diasurgical/devilutionX/archive/${PV}.tar.gz -> ${P}.tar.gz"
  13. S="${WORKDIR}/devilutionX-${PV}"
  14. KEYWORDS="~amd64 ~x86"
  15. fi
  16. LICENSE="Unlicense"
  17. SLOT="0"
  18. IUSE="debug"
  19. RDEPEND="
  20. dev-libs/libsodium
  21. media-libs/libsdl2[haptic]
  22. media-libs/sdl2-mixer
  23. media-libs/sdl2-ttf
  24. "
  25. DEPEND="${RDEPEND}"
  26. BDEPEND="
  27. virtual/pkgconfig
  28. "
  29. src_configure() {
  30. local mycmakeargs=(
  31. -DBINARY_RELEASE=ON
  32. -DDEBUG="$(usex debug)"
  33. )
  34. cmake-utils_src_configure
  35. }
  36. src_install() {
  37. dobin ${BUILD_DIR}/devilutionx
  38. }
  39. pkg_postinst() {
  40. einfo "In order to play the game you need to install the file"
  41. einfo " diabdat.mpq"
  42. einfo "from the original game CD into the following directory:"
  43. einfo " \${HOME}/.local/share/diasurgical/devilution/"
  44. einfo "and make sure it's writeable (chmod u+w)."
  45. }