logo

overlay

My own overlay for experimentations, use with caution, no support is provided

devilutionX-9999.ebuild (1126B)


      1 # Copyright 1999-2019 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit cmake-utils
      7 
      8 DESCRIPTION="Diablo build for modern operating systems"
      9 HOMEPAGE="https://github.com/diasurgical/devilutionX"
     10 if [[ "${PV}" == 9999 ]] ; then
     11 	inherit git-r3
     12 	EGIT_REPO_URI="https://github.com/diasurgical/devilutionX.git"
     13 else
     14 	SRC_URI="https://github.com/diasurgical/devilutionX/archive/${PV}.tar.gz -> ${P}.tar.gz"
     15 	KEYWORDS="~amd64 ~x86"
     16 fi
     17 
     18 LICENSE="Unlicense"
     19 SLOT="0"
     20 
     21 IUSE="debug"
     22 
     23 RDEPEND="
     24 	dev-libs/libsodium
     25 	media-libs/libsdl2[haptic]
     26 	media-libs/sdl2-mixer
     27 	media-libs/sdl2-ttf
     28 "
     29 DEPEND="${RDEPEND}"
     30 BDEPEND="
     31 	virtual/pkgconfig
     32 "
     33 
     34 src_configure() {
     35 	local mycmakeargs=(
     36 		-DBINARY_RELEASE=ON
     37 		-DDEBUG="$(usex debug)"
     38 	)
     39 	cmake-utils_src_configure
     40 }
     41 
     42 #src_install() {
     43 #	dobin ${BUILD_DIR}/${PN}
     44 #}
     45 
     46 pkg_postinst() {
     47 	einfo "In order to play the game you need to install the file"
     48 	einfo "  diabdat.mpq"
     49 	einfo "from the original game CD into the following directory:"
     50 	einfo "  \${HOME}/.local/share/diasurgical/devilution/"
     51 	einfo "and make sure it's writeable (chmod u+w)."
     52 }