logo

overlay

My own overlay for experimentations, use with caution, no support is provided

devilutionX-0.5.0.ebuild (1230B)


      1 # Copyright 1999-2019 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 CMAKE_MAKEFILE_GENERATOR=emake
      7 
      8 inherit cmake-utils multilib
      9 
     10 DESCRIPTION="Diablo build for modern operating systems"
     11 HOMEPAGE="https://github.com/diasurgical/devilutionX"
     12 if [[ "${PV}" == 9999 ]] ; then
     13 	inherit git-r3
     14 	EGIT_REPO_URI="https://github.com/diasurgical/devilutionX.git"
     15 else
     16 	SRC_URI="https://github.com/diasurgical/devilutionX/archive/${PV}.tar.gz -> ${P}.tar.gz"
     17 	KEYWORDS="~amd64 ~x86"
     18 fi
     19 
     20 LICENSE="Unlicense"
     21 SLOT="0"
     22 
     23 IUSE="debug"
     24 
     25 RDEPEND="
     26 	dev-libs/libsodium
     27 	media-libs/libsdl2[haptic]
     28 	media-libs/sdl2-mixer
     29 	media-libs/sdl2-ttf
     30 "
     31 DEPEND="${RDEPEND}"
     32 BDEPEND="
     33 	virtual/pkgconfig
     34 "
     35 
     36 src_configure() {
     37 	# for some reason cmake doesn't find sodium
     38 	local mycmakeargs=(
     39 		-DBINARY_RELEASE=ON
     40 		-DDEBUG="$(usex debug)"
     41 		-DNONET=yes
     42 	)
     43 
     44 	cmake-utils_src_configure
     45 }
     46 
     47 src_install() {
     48 	dobin ${BUILD_DIR}/devilutionx
     49 }
     50 
     51 pkg_postinst() {
     52 	einfo "In order to play the game you need to install the file"
     53 	einfo "  diabdat.mpq"
     54 	einfo "from the original game CD into the following directory:"
     55 	einfo "  \${HOME}/.local/share/diasurgical/devilution/"
     56 	einfo "and make sure it's writeable (chmod u+w)."
     57 }