logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

brux-gdk-9999.ebuild (613B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="Free runtime and development kit using SDL and Squirrel"
  6. HOMEPAGE="https://github.com/KelvinShadewing/brux-gdk"
  7. EGIT_REPO_URI="https://github.com/lanodan/brux-gdk"
  8. S="${WORKDIR}/${P}/rte"
  9. LICENSE="AGPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. RDEPEND="
  13. dev-lang/squirrel
  14. media-libs/libsdl2
  15. media-libs/sdl2-image
  16. media-libs/sdl2-gfx
  17. media-libs/sdl2-mixer
  18. media-libs/sdl2-net
  19. "
  20. DEPEND="${RDEPEND}"
  21. src_install() {
  22. einstalldocs
  23. dobin bin/brux
  24. }