logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

reicast-8.1.ebuild (687B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit toolchain-funcs
  5. DESCRIPTION="A Dreamcast Emulator"
  6. HOMEPAGE="https://reicast.com/"
  7. LICENSE="GPL-2"
  8. SRC_URI="https://github.com/reicast/reicast-emulator/archive/r${PV}.tar.gz -> ${P}.tar.gz"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. DEPEND="
  12. media-libs/alsa-lib
  13. media-libs/mesa[egl(+),gles2]
  14. "
  15. S="${WORKDIR}/reicast-emulator-r${PV}/shell/linux"
  16. src_compile() {
  17. emake \
  18. CC="$(tc-getCC)" \
  19. CXX="$(tc-getCXX)" \
  20. AS="$(tc-getAS)" \
  21. STRIP="$(tc-getSTRIP)" \
  22. LD="$(tc-getLD)"
  23. }
  24. src_install() {
  25. emake DESTDIR="${D}" PREFIX="/usr" install
  26. }