logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

tinymania-9999.ebuild (542B)


  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit git-r3 eutils
  5. DESCRIPTION="A VSRG clone for playing .osu files."
  6. HOMEPAGE="https://git.sakamoto.gq/eal/tinymania"
  7. EGIT_REPO_URI="https://git.sakamoto.gq/eal/tinymania.git"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS=""
  11. IUSE=""
  12. DEPEND="media-libs/libsfml"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. default
  16. epatch "${FILESDIR}/tinymania-fix-Makefile.patch"
  17. }
  18. src_install() {
  19. emake install DESTDIR="${D}" PREFIX="/usr/games"
  20. }