logo

overlay

My (experimental) gentoo overlay

taisei-1.3.ebuild (968B)


      1 # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit meson
      7 
      8 DESCRIPTION="Clone of the Touhou series, written in C using SDL/OpenGL/OpenAL."
      9 HOMEPAGE="http://taisei-project.org/"
     10 LICENSE="BSD"
     11 SLOT="0"
     12 SRC_URI="https://github.com/taisei-project/taisei/releases/download/v${PV}/${PN}-v${PV}.tar.xz"
     13 KEYWORDS="~amd64"
     14 IUSE="libzip"
     15 
     16 S="${WORKDIR}/${PN}-v${PV}"
     17 
     18 DEPEND="
     19 	media-libs/freetype:2
     20 	>=media-libs/libpng-1.5
     21 	media-libs/libsdl2
     22 	media-libs/sdl2-mixer
     23 	media-libs/libwebp
     24 	sys-libs/zlib
     25 	libzip? ( dev-libs/libzip )
     26 "
     27 
     28 src_prepare() {
     29 	sed -i '/strip=true/d' meson.build || die "Failed removing auto-stripping"
     30 	sed -i "s/doc_path = join.*/doc_path = join_paths(datadir, \'doc\', \'taisei-${PV}\')/" \
     31 		meson.build \
     32 		|| die "Failed changing doc_path"
     33 	default
     34 }
     35 
     36 src_configure() {
     37 	local emesonargs=(
     38 		$(meson_use libzip enable_zip)
     39 	)
     40 	meson_src_configure
     41 }