logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

pinball-table-gnu-9999.ebuild (669B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. if [[ "${PV}" == "9999" ]]
  5. then
  6. EGIT_REPO_URI="https://github.com/rzr/pinball-table-gnu"
  7. inherit git-r3
  8. else
  9. SRC_URI="https://github.com/rzr/pinball-table-gnu/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. KEYWORDS="~amd64 ~ppc ~sparc ~x86"
  11. fi
  12. DESCRIPTION="GNU table for games-arcade/emilia-pinball"
  13. HOMEPAGE="https://github.com/rzr/pinball-table-gnu"
  14. LICENSE="GPL-2+ GPL-3+ Free-Art-1.3 CC-BY-SA-3.0"
  15. SLOT="0"
  16. IUSE=""
  17. RDEPEND="
  18. media-libs/libsdl2
  19. >=games-arcade/emilia-pinball-0.3.2020
  20. "
  21. DEPEND="${RDEPEND}"
  22. src_prepare() {
  23. default
  24. ./bootstrap || die
  25. }