logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

osu-lazer-9999.999.9.ebuild (1205B)


  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # Scavenged parts from https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=osu-lazer-git
  4. EAPI=6
  5. inherit git-r3
  6. DESCRIPTION="rhythm is just a *click* away!"
  7. HOMEPAGE="https://github.com/ppy/osu"
  8. SRC_URI=""
  9. LICENSE="MIT CC-BY-NC-4.0"
  10. SLOT="0"
  11. KEYWORDS=""
  12. IUSE=""
  13. EGIT_REPO_URI="https://github.com/ppy/osu.git"
  14. DEPEND="
  15. >dev-lang/mono-5.4.0.201
  16. >dev-dotnet/nuget-4.0.0"
  17. RDEPEND="${DEPEND}"
  18. src_prepare() {
  19. mkdir -p "osu.Game/bin/Release" || die "Failed creating directory for Release"
  20. ln -s "/usr/lib/mono/4.5/Facades/netstandard.dll" "osu.Game/bin/Release" || die "Failed symlinking netstandard.dll from mono"
  21. nuget restore || die "Failed restoring NuGet packages (do you have internet?)"
  22. default
  23. }
  24. src_compile() {
  25. export MONO_IOMAP="case"
  26. xbuild /property:Configuration=Release
  27. rm "osu.Game/bin/Release/netstandard.dll"
  28. rm "osu.Desktop/bin/Release/netstandard.dll"
  29. }
  30. src_install() {
  31. cd "osu.Desktop/bin/Release"
  32. insinto "/usr/lib/${PN}"
  33. for binary in *.exe *.dll; do
  34. doins "$binary"
  35. done
  36. doins 'libbass.'*'.so'
  37. doins 'libbass_fx.'*'.so'
  38. doins 'libe_sqlite3.so'
  39. }