logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

kobodeluxe-9999.ebuild (624B)


  1. # Copyright 2024 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake git-r3
  5. DESCRIPTION="An SDL port of xkobo, a addictive space shoot-em-up"
  6. HOMEPAGE="http://www.olofson.net/kobodl/ https://github.com/olofson/kobodeluxe/"
  7. EGIT_REPO_URI="https://github.com/olofson/kobodeluxe"
  8. SLOT="0"
  9. RDEPEND="
  10. media-libs/libsdl
  11. media-libs/sdl-image
  12. "
  13. DEPEND="${RDEPEND}"
  14. # https://github.com/olofson/kobodeluxe/pull/8
  15. PATCHES=(
  16. "${FILESDIR}/0001-CMake-Fix-desktop-icon-installation.patch"
  17. "${FILESDIR}/0002-CMake-Fix-sfx-installation.patch"
  18. )