logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

emilia-pinball-9999.ebuild (872B)


  1. # Copyright 2021-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. if [[ "${PV}" == "9999" ]]
  5. then
  6. EGIT_REPO_URI="https://github.com/adoptware/pinball"
  7. inherit git-r3
  8. else
  9. MY_P="pinball-${PV}"
  10. SRC_URI="https://github.com/rzr/pinball/archive/${PV}.tar.gz -> ${P}.tar.gz"
  11. S="${WORKDIR}/${MY_P}"
  12. KEYWORDS="~amd64 ~ppc ~sparc ~x86"
  13. fi
  14. DESCRIPTION="SDL OpenGL pinball game"
  15. HOMEPAGE="https://github.com/adoptware/pinball"
  16. LICENSE="GPL-2 CC0-1.0"
  17. SLOT="0"
  18. IUSE="gles1-only"
  19. # Note: media-libs/libsdl2::gentoo doesn't have USE=gles1 yet
  20. RDEPEND="
  21. dev-libs/libltdl
  22. media-libs/libsdl2[joystick,opengl,video]
  23. media-libs/sdl2-image
  24. gles1-only? ( media-libs/libsdl2[gles1(-)] )
  25. virtual/opengl
  26. "
  27. DEPEND="
  28. ${RDEPEND}
  29. "
  30. src_prepare() {
  31. default
  32. ./bootstrap || die
  33. }
  34. src_configure() {
  35. econf $(use_enable gles1-only gles)
  36. }