logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

crypt_of_the_necrodancer-1.29.14917.ebuild (1055B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit unpacker xdg
  5. MY_PV="$(ver_rs 1- _)"
  6. DESCRIPTION="Crypt of the Necrodancer (GOG)"
  7. HOMEPAGE="https://www.gog.com/game/crypt_of_the_necrodancer"
  8. LICENSE=""
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. SRC_URI="${PN}_en_${MY_PV}.sh"
  12. S="${WORKDIR}"
  13. dir="/opt/${PN}"
  14. RESTRICT="bindist fetch strip"
  15. QA_PREBUILT="${dir#/}/*"
  16. BDEPEND="app-arch/unzip"
  17. DEPEND="
  18. media-libs/openal[abi_x86_32]
  19. media-libs/glfw:2[abi_x86_32]
  20. media-libs/libogg[abi_x86_32]
  21. media-libs/libvorbis[abi_x86_32]
  22. "
  23. RDEPEND="${DEPEND}"
  24. pkg_nofetch() {
  25. elog "Please buy and download ${A} from:"
  26. elog " https://www.gog.com/game/crypt_of_the_necrodancer"
  27. elog "and move it to your distfiles directory."
  28. }
  29. src_unpack() {
  30. unpack_zip ${A}
  31. }
  32. src_install() {
  33. exeinto "${dir}"
  34. doexe data/noarch/game/NecroDancer
  35. dosym "${dir}/NecroDancer" "/usr/bin/${PN}"
  36. insinto "${dir}"
  37. doins -r data/noarch/game/data/
  38. doins -r data/noarch/game/fmod/
  39. }