logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

teeworlds-0.7.3.1.ebuild (1031B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit cmake-utils
  5. DESCRIPTION="Online multi-player platform 2D shooter"
  6. HOMEPAGE="https://www.teeworlds.com/"
  7. SRC_URI="https://github.com/teeworlds/teeworlds/releases/download/${PV}/${P}-src.tar.gz"
  8. # License of stuff in src/engine/external (* disabled)
  9. # json-parser: BSD-2
  10. # md5: ZLIB
  11. # pnglite*: ZLIB
  12. # wavpack*: BSD
  13. # zlib*: ZLIB
  14. LICENSE="ZLIB CC-BY-SA-3.0"
  15. SLOT="0"
  16. KEYWORDS="~amd64 ~x86"
  17. IUSE="dedicated test"
  18. S="${WORKDIR}/${P}-src"
  19. DEPEND="
  20. dev-lang/python
  21. sys-libs/zlib:=
  22. virtual/opengl:=
  23. !dedicated? (
  24. media-libs/freetype:=
  25. media-libs/libsdl2:=
  26. media-libs/pnglite:=
  27. media-sound/wavpack:=
  28. x11-libs/libX11:=
  29. )
  30. dev-libs/openssl:=
  31. test? ( dev-cpp/gtest )
  32. "
  33. RDEPEND="${DEPEND}"
  34. src_configure() {
  35. local mycmakeargs=(
  36. -DDOWNLOAD_GTEST=OFF
  37. -DDOWNLOAD_DEPENDENCIES=OFF
  38. -DPREFER_BUNDLED_LIBS=OFF
  39. -DCLIENT=$(usex !dedicated)
  40. )
  41. cmake-utils_src_configure
  42. }