logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

git-repair-1.20200102.ebuild (1106B)


  1. # Copyright 2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CABAL_FEATURES="haddock hoogle profile"
  5. inherit haskell-cabal
  6. DESCRIPTION="repairs a damanged git repisitory"
  7. HOMEPAGE="https://git-repair.branchable.com/"
  8. SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
  9. LICENSE="AGPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. ISUE=""
  13. RDEPEND="
  14. dev-haskell/async:=[profile?]
  15. dev-haskell/attoparsec:=[profile?]
  16. dev-haskell/data-default:=[profile?]
  17. >=dev-haskell/exceptions-0.6:=[profile?]
  18. >=dev-haskell/filepath-bytestring-1.4.2.1.0:=[profile?]
  19. dev-haskell/hslogger:=[profile?]
  20. dev-haskell/ifelse:=[profile?]
  21. dev-haskell/mtl:=[profile?]
  22. dev-haskell/network:=[profile?]
  23. dev-haskell/network-uri:=[profile?]
  24. >=dev-haskell/optparse-applicative-0.14.1:=[profile?]
  25. dev-haskell/quickcheck:=[profile?]
  26. dev-haskell/setenv:=[profile?]
  27. dev-haskell/split:=[profile?]
  28. dev-haskell/text:=[profile?]
  29. >=dev-haskell/unix-compat-0.5:=[profile?]
  30. dev-haskell/utf8-string:=[profile?]
  31. "
  32. DEPEND="
  33. ${RDEPEND}
  34. >=dev-lang/ghc-8.4.1
  35. "