logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

rebar-3.11.1.ebuild (807B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit bash-completion-r1 rebar3
  5. DESCRIPTION="Sophisticated build-tool for Erlang projects that follows OTP principles"
  6. HOMEPAGE="https://www.rebar3.org/"
  7. LICENSE="Apache-2.0"
  8. SRC_URI="https://github.com/erlang/rebar3/archive/3.11.1.tar.gz -> ${P}.tar.gz"
  9. SLOT="3"
  10. KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  11. IUSE=""
  12. RESTRICT="network-sandbox"
  13. DEPEND="dev-lang/erlang"
  14. RDEPEND="${DEPEND}"
  15. S="${WORKDIR}/${PN}3-${PV}"
  16. src_compile() {
  17. ./bootstrap || die
  18. }
  19. src_test() {
  20. ./rebar3 ct || die
  21. }
  22. src_install() {
  23. rebar3_src_install
  24. dobin rebar3
  25. doman manpages/rebar3.1
  26. dodoc rebar.config.sample
  27. dobashcomp priv/shell-completion/bash/rebar3
  28. }