logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

oyacc-6.6.ebuild (720B)


  1. # Copyright 2024 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Portable OpenBSD Yacc"
  5. HOMEPAGE="https://github.com/ibara/yacc"
  6. SRC_URI="https://github.com/ibara/yacc/archive/refs/tags/oyacc-${PV}.tar.gz"
  7. S="${WORKDIR}/yacc-oyacc-${PV}/"
  8. LICENSE="BSD ISC public-domain"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="static"
  12. src_configure() {
  13. # Somehow BINDIR isn't set in the generated Makefile
  14. export BINDIR="${EPREFIX}/usr/bin"
  15. # --disable-yacc: Installs as oyacc+oyyfix rather than yacc+yyfix
  16. ./configure \
  17. --prefix="${EPREFIX}/usr" \
  18. --mandir="${EPREFIX}/usr/share/man" \
  19. --disable-yacc \
  20. $(use_enable static) \
  21. || die
  22. }