logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

itstool-2.0.5.ebuild (907B)


  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  3. # Distributed under the terms of the GNU General Public License v2
  4. EAPI=7
  5. PYTHON_COMPAT=( python2_7 python3_{5,6} )
  6. PYTHON_REQ_USE="xml"
  7. inherit python-single-r1
  8. DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
  9. HOMEPAGE="http://itstool.org/"
  10. SRC_URI="http://files.itstool.org/itstool/${P}.tar.bz2"
  11. # files in /usr/share/itstool/its are HPND/as-is || GPL-3
  12. LICENSE="GPL-3+ || ( HPND GPL-3+ )"
  13. SLOT="0"
  14. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-linux"
  15. IUSE=""
  16. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  17. RDEPEND="${PYTHON_DEPS}
  18. dev-libs/libxml2[python,${PYTHON_USEDEP}]"
  19. DEPEND="${RDEPEND}"
  20. DOCS=(ChangeLog NEWS) # AUTHORS, README are empty
  21. src_prepare() {
  22. python_fix_shebang .
  23. default
  24. }