logo

overlay

My own overlay for experimentations, use with caution, no support is provided

go-deblob-9999.ebuild (820B)


      1 # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 EGO_PN="hacktivis.me/git/go-deblob"
      7 
      8 inherit git-r3 go-module
      9 
     10 DESCRIPTION="remove binary blobs from a directory"
     11 HOMEPAGE="https://hacktivis.me/git/go-deblob/"
     12 # BSD: hacktivis.me/git/go-deblob, git.sr.ht/~sircmpwn/getopt
     13 LICENSE="BSD"
     14 SLOT="0"
     15 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc64 ~s390 ~sh ~sparc ~x86"
     16 
     17 EGIT_REPO_URI="https://hacktivis.me/git/go-deblob.git"
     18 EGIT_MIN_CLONE_TYPE="single+tags"
     19 # network needed for go-module_live_vendor
     20 RESTRICT="network-sandbox"
     21 
     22 src_unpack() {
     23 	git-r3_src_unpack
     24 
     25 	# Hotfix against go-module.eclass
     26 	mkdir "${S}/vendor"
     27 	go-module_live_vendor
     28 }
     29 
     30 src_install() {
     31 	emake DESTDIR="${D}" PREFIX="/usr" install
     32 	einstalldocs
     33 }