logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

go-deblob-1.0.0.ebuild (1512B)


  1. # Copyright 2019-2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. EGO_PN="hacktivis.me/git/go-deblob"
  5. inherit go-module
  6. DESCRIPTION="remove binary blobs from a directory"
  7. HOMEPAGE="https://hacktivis.me/git/go-deblob/"
  8. # BSD: hacktivis.me/git/go-deblob, git.sr.ht/~sircmpwn/getopt
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc64 ~s390 ~sh ~sparc ~x86"
  12. EGO_SUM=(
  13. "git.sr.ht/~sircmpwn/getopt v0.0.0-20190808004552-daaf1274538b h1:da5JBQ6dcW14aWnEf/pFRIMV2PsqTQEWmR+V2sw5oxU="
  14. "git.sr.ht/~sircmpwn/getopt v0.0.0-20190808004552-daaf1274538b/go.mod h1:wMEGFFFNuPos7vHmWXfszqImLppbc0wEhh6JBfJIUgw="
  15. "github.com/davecgh/go-spew v1.1.0 h1:ZDRjVQ15GmhC3fiQ8ni8+OwkZQO4DARzQgrnXU1Liz8="
  16. "github.com/davecgh/go-spew v1.1.0/go.mod h1:J7Y8YcW2NihsgmVo/mv3lAwl/skON4iLHjSsI+c5H38="
  17. "github.com/pmezard/go-difflib v1.0.0 h1:4DBwDE0NGyQoBHbLQYPwSUPoCMWR5BEzIk/f1lZbAQM="
  18. "github.com/pmezard/go-difflib v1.0.0/go.mod h1:iKH77koFhYxTK1pcRnkKkqfTogsbg7gZNVY4sRDYZ/4="
  19. "github.com/stretchr/objx v0.1.0/go.mod h1:HFkY916IF+rwdDfMAkV7OtwuqBVzrE8GR6GFx+wExME="
  20. "github.com/stretchr/testify v1.3.0 h1:TivCn/peBQ7UY8ooIcPgZFpTNSz0Q2U6UrFlUfqbe0Q="
  21. "github.com/stretchr/testify v1.3.0/go.mod h1:M5WIy9Dh21IEIfnGCwXGc5bZfKNJtfHm1UVUgZn+9EI="
  22. )
  23. go-module_set_globals
  24. SRC_URI="https://hacktivis.me/releases/${P}.tar.gz
  25. ${EGO_SUM_SRC_URI}"
  26. src_install() {
  27. emake DESTDIR="${D}" PREFIX="/usr" install
  28. einstalldocs
  29. }