logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

glslang-11.10.0.ebuild (649B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CMAKE_ECLASS="cmake"
  5. PYTHON_COMPAT=( python3_{8..12} )
  6. inherit cmake-multilib python-any-r1
  7. # https://bugs.gentoo.org/show_bug.cgi?id=760777
  8. MYCMAKEARGS="-DENABLE_PCH=OFF"
  9. DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
  10. HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
  11. SRC_URI="https://github.com/KhronosGroup/glslang/archive/${PV}.tar.gz -> ${P}.tar.gz"
  12. KEYWORDS="~amd64 ~x86"
  13. LICENSE="BSD"
  14. SLOT="0"
  15. BDEPEND="${PYTHON_DEPS}"