dot2tex-2.11.2.ebuild (1130B)
- # Copyright 1999-2018 Gentoo Authors
- # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
- # Distributed under the terms of the GNU General Public License v2
- EAPI=7
- # Upstream supports python-3.7
- PYTHON_COMPAT=( python2_7 python3_{5,6} )
- inherit distutils-r1
- DESCRIPTION="A Graphviz to LaTeX converter"
- HOMEPAGE="https://dot2tex.readthedocs.io/ https://github.com/kjellmf/dot2tex"
- SRC_URI="https://github.com/kjellmf/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
- LICENSE="MIT"
- SLOT="0"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
- IUSE="doc examples"
- DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
- RDEPEND="
- dev-python/pydot[${PYTHON_USEDEP}]
- media-gfx/graphviz"
- DEPEND="${DEPEND}
- doc? ( dev-python/sphinx )"
- python_compile_all() {
- if use doc ; then
- cd "${S}/docs"
- emake html
- fi
- }
- python_install_all() {
- distutils-r1_python_install_all
- if use doc; then
- dodoc -r docs/_build/html/*
- fi
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- }