logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

dot2tex-2.11.2.ebuild (1130B)


  1. # Copyright 1999-2018 Gentoo Authors
  2. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  3. # Distributed under the terms of the GNU General Public License v2
  4. EAPI=7
  5. # Upstream supports python-3.7
  6. PYTHON_COMPAT=( python2_7 python3_{5,6} )
  7. inherit distutils-r1
  8. DESCRIPTION="A Graphviz to LaTeX converter"
  9. HOMEPAGE="https://dot2tex.readthedocs.io/ https://github.com/kjellmf/dot2tex"
  10. SRC_URI="https://github.com/kjellmf/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
  11. LICENSE="MIT"
  12. SLOT="0"
  13. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
  14. IUSE="doc examples"
  15. DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
  16. RDEPEND="
  17. dev-python/pydot[${PYTHON_USEDEP}]
  18. media-gfx/graphviz"
  19. DEPEND="${DEPEND}
  20. doc? ( dev-python/sphinx )"
  21. python_compile_all() {
  22. if use doc ; then
  23. cd "${S}/docs"
  24. emake html
  25. fi
  26. }
  27. python_install_all() {
  28. distutils-r1_python_install_all
  29. if use doc; then
  30. dodoc -r docs/_build/html/*
  31. fi
  32. if use examples; then
  33. dodoc -r examples
  34. docompress -x /usr/share/doc/${PF}/examples
  35. fi
  36. }